(Object)#0 message = “faultCode:INVALID_AMF_MESSAGE faultString:’Invalid AMF message’ faultDetail:’ Warning: Cannot modify header information – headers already sent by (output started at /a/long/path/to/a/site/root/fileDirectory/my_necessary_class.php:464) in /a/long/path/to/a/site/root/amfphp/core/shared/exception/php4Exception.php on line 38 ‘” name = “Error” rootCause = (null)

Hi,

After 10 hours of endless efforts, I have fixed this problem. I’ve tested some php files on my server with AMFPHP and Flex. Everything is working as I expected. However, when I moved all of these files to my clients server, I started to get error from AMFPHP browser as follows;

(Object)#0
message = “faultCode:INVALID_AMF_MESSAGE faultString:’Invalid
AMF message’ faultDetail:’Warning: Cannot modify header
information – headers already sent by
(output started at /a/long/path/to/a/site/root/fileDirectory/
my_necessary_class.php:464) in
/a/long/path/to/a/site/root/amfphp/core/shared/exception/php4Exception.php
on line 38
‘”
name = “Error”
rootCause = (null)

What da hell? Everything was fine. What happend now? There is a guy
who got this type of error from AMFPHP and his solution for
the problem is here. It can work for you. But, it doesn’t work for me.
in order to get rid of this problem, I checked my .htaccess file
in my server. As you know .htaccess is a hidden file in your server.
So first of all, make activate ‘show invisible files’ option from
your ftp application. Then, make a back-up of .htaccess file and
open it in a text editor. When I opened my client’s .htaccess,
I realized that there is two lines of code that blocking the server
to use PHP 5. However, my PHP classes are optimized for PHP 5.
Here is the solution, just delete these codes which blocks your PHP
version. By the way, you may not have anything in your .htaccess.
In this case, probably the first link solves your problem.

Leave a Reply

Your email address will not be published. Required fields are marked *